GNOME System/Event Sounds

OSS specific Linux discussion (x86/amd64)

Moderators: cesium, dev, kodachi, hannu

GNOME System/Event Sounds

Postby Temüjin » Mon Sep 28, 2009 1:25 pm

EVENT SOUNDS
A libcanberra-gstreamer 0.22 package is now available in Debian squeeze and sid, but it still does not work properly: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=563353
For older versions of Debian or Ubuntu distros, I've found that no modification of libcanberra is necessary if one uses the libasound plugin trick: http://www.opensound.com/wiki/index.php ... _Emulation
For Ubuntu 9.10/Karmic, there is a PPA with libcanberra packages recompiled to use gstreamer only: https://launchpad.net/~dtl131/+archive/ppa

SOUND PREFERENCES
For Ubuntu 9.10: one cannot access the sound preferences without having PulseAudio installed (i.e. clicking on System->Preferences->Sound results in an error message "waiting for sound system to respond"). However, one can still run the old gnome-sound-properties with a couple of files. The attached file has 32bit/x86 and 64bit/x86-64 versions of the old gnome-sound-properties program. Move sound-properties.glade (this file is not architecture-dependent) to /usr/local/share/gnome-control-center/glade/ (you'll probably need to create this directory). Move the appropriate version of the gnome-sound-properties file to /usr/local/bin. You can run this program from the command-line or create a shortcut for it.

EDIT: If /usr/local doesn't work, then just use /usr (though it's technically against Debian policy for a user to move files there)

Note: If you need a different architecture, get the appropriate .deb at https://launchpad.net/ubuntu/+source/gn ... 0-0ubuntu3 . DO NOT install the .deb, just right-click it and open it in the Archive Manager. The file you need is data.tar.gz/./usr/bin/gnome-sound-properties. Extract that file and follow the above instructions.
Attachments
soundproperties.tar.gz
(73.76 KiB) Downloaded 8544 times
Last edited by Temüjin on Sat Jan 02, 2010 8:37 am, edited 4 times in total.
Temüjin
Member
 
Posts: 84
Joined: Tue Jul 24, 2007 7:55 pm
Location: Pennsylvania, USA

Re: GNOME System/Event Sounds

Postby Temüjin » Fri Oct 09, 2009 9:25 am

THIS POST SHOWS HOW TO CONFIGURE GSTREAMER THROUGH THE COMMAND-LINE. MOST PEOPLE WILL PROBABLY WANT TO INSTALL THE CLASSIC GNOME SOUND PREFERENCES GUI DIALOG AS INSTRUCTED IN THE FIRST POST.

This post is about configuring gstreamer when you can't access the preferences through a GUI. I'll just include it in this thread rather than making a new one.
You cannot access the sound preferences in Ubuntu 9.10/Karmic if you do not have PulseAudio (P.A.) installed. IIRC, this is because of Ubuntu customization and does not affect GNOME 2.28 in general.
I understand if the new mixer Ubuntu uses requires P.A., but neither system/event sounds nor gstreamer require P.A., so it seems silly to require P.A. to access their preferences, but I digress..

Code: Select all
gst-inspect-0.10 | grep OSS

should output something like:
Code: Select all
ossaudio:  osssink: Audio Sink (OSS)
ossaudio:  osssrc: Audio Source (OSS)
ossaudio:  ossmixer: OSS Mixer
oss4:  oss4mixer: OSS v4 Audio Mixer
oss4:  oss4src: OSS v4 Audio Source
oss4:  oss4sink: OSS v4 Audio Sink

The oss4 options will only be available if you have the gstreamer0.10-plugins-bad package installed.

Code: Select all
gstreamer-properties

This command will give you a GUI dialog with limited gstreamer options. If the gst-inspect command didn't show oss4-specific outputs: select 'Open Sound System' for Output and Input plugins. If the oss4-specific options are available: for the 'Default Output' option, select Custom for the plugin and enter 'oss4sink' (without the apostrophes) for the pipeline. For 'Default Input' option, select 'Custom' for plugin and enter 'oss4src' (no apostrophes) for the pipeline (or you can select 'Silence' if you do not plan to use the input).
Use the 'Test' buttons to make sure your options work (you may need to have something connected for the input).

Code: Select all
gconf-editor

We are interested in the /desktop/gnome/sound and /system/gstreamer/0.10/audio/default paths.
In /desktop/gnome/sound , you can toggle event sounds and select the sound theme. There are also some values for controlling volume with multimedia keys, but I was not able to get this feature to work, even copying the values from my Ubuntu 9.04 install (where that feature does work).

In /system/gstreamer/0.10/audio/default , you'll see similar options to the gstreamer-properties dialog. Again, enter 'osssink' or 'oss4sink' for the audio sink options where they are not already filled in, such as 'chataudiosink' and 'musicaudiosink'
Last edited by Temüjin on Mon Oct 12, 2009 12:50 pm, edited 1 time in total.
Temüjin
Member
 
Posts: 84
Joined: Tue Jul 24, 2007 7:55 pm
Location: Pennsylvania, USA

Re: GNOME System/Event Sounds

Postby cesium » Fri Oct 09, 2009 11:23 pm

This is excellent work. Perhaps you could edit the wiki, or do you prefer I do so?
cesium
Developer
 
Posts: 902
Joined: Sun Aug 12, 2007 12:51 am

Re: GNOME System/Event Sounds

Postby Temüjin » Sat Oct 24, 2009 1:10 am

cesium wrote:Perhaps you could edit the wiki, or do you prefer I do so?

I'll do it. You do enough around here :P
Attachments
oss4gstr.tar.gz
Script to configure gstreamer
(486 Bytes) Downloaded 5500 times
Temüjin
Member
 
Posts: 84
Joined: Tue Jul 24, 2007 7:55 pm
Location: Pennsylvania, USA

Re: GNOME System/Event Sounds

Postby igorzwx » Mon Oct 26, 2009 1:29 am

Gnome Volume Control is now working on my Ubuntu 9.10

Just copied "gnome-volume-control" from Ubuntu 9.04 to Ubuntu 9.10 and renamed


Step 1: Make a copy

cp /usr/bin/gnome-volume-control ~/Desktop

Step 2: Rename:

mv gnome-volume-control gnome-volume-control2

Step 3: Copy it from Ubuntu 9.04 to Ubuntu 9.10

Step 4: Install it on Ubuntu 9.10

(check first, if it is still executable)

sudo cp gnome-volume-control2 /usr/bin/


Run it from Terminal:

gnome-volume-control2

or add icon to panel

--------------------------------------------------------------------------------------
EDIT:

"gnome-volume-control" is in the package gnome-media_2.26.0-0ubuntu3_i386.deb

You can download it here:
http://packages.ubuntu.com/jaunty/gnome-media

As usual, open with Archive Manager and extract "gnome-volume-control"

Then rename and install (sudo cp ...)
It is necessary to rename, because there is already a new "gnome-volume-control" which does not work, but can be updated sooner or later.

Perhaps, you may have a better idea how to fix the problem.
igorzwx
Known Member
 
Posts: 1000
Joined: Sun Jun 28, 2009 9:31 pm

Re: GNOME System/Event Sounds

Postby igorzwx » Tue Mar 23, 2010 5:37 pm

Temüjin wrote:
cesium wrote:Perhaps you could edit the wiki, or do you prefer I do so?

I'll do it. You do enough around here :P

ATTACHMENTS
oss4gstr.tar.gz
download/file.php?id=2
Script to configure gstreamer
(486 Bytes) Downloaded 477 times


Temüjin's script, oss4gstr.sh, works on Arch Linux, and "gnome-sound-properties" too.

I downloaded the script and applied it as is. It did the work.

Then, I installed Temüjin's "gnome-sound-properties" on Arch Linux. It works perfectly.

The same ritual was applied:

Step 1: Download Temüjin's soundproperties.tar.gz and unpack it
viewtopic.php?f=3&t=3324#p13359

Step 2: Perform the magic ritual:

$ mv gnome-sound-properties gnome-sound-properties2
$ sudo su
Password:
# cp gnome-sound-properties2 /usr/bin/
# mkdir /usr/share/gnome-control-center/glade/
# cp sound-properties.glade /usr/share/gnome-control-center/glade/

Step 3: Run on terminal:

$ gnome-sound-properties2

You can add it to menu.

EDIT: If you need GNOME System/Event Sounds, you may try this:

# pacman -Rd libcanberra

$ yaourt libcanberra-oss
igorzwx
Known Member
 
Posts: 1000
Joined: Sun Jun 28, 2009 9:31 pm


Return to Linux

Who is online

Users browsing this forum: Google [Bot] and 1 guest