How to enable "production quality with extra precision"?

OSS specific Linux discussion (x86/amd64)

Moderators: cesium, dev, kodachi, hannu

Re: How to enable "production quality with extra precision"?

Postby igorzwx » Sat Jan 16, 2010 6:49 pm

cesium wrote:A. FreeBSD doesn't use ALSA, but it's own sound system (the interface to it is OSSv3 API).

B. AFAICT, that comparison page was done by the main contributor to said soundsystem a while ago (That's why it doesn't mention FreeBSD 8 is out already).

C. You're right that the setup should be disclosed (for reproducability).


Many thanks for corrections!
You see, it is not a rocket science, and we may clarify this problem step-by-step.

1. If a person publishes results of an experiments and does not disclose the setup, there should be a reason for this. What is obvious is that we are not invited to reproduce the experiment and question the validity of it.

2. There are many different algorithms of resampling. Some of them are more exact than others. It might be interesting to compare them, of course.

3. An exact algorithm may take up lots of CPU (around 20-30%, or even more). This is particularly true for the so called "Secret Rabbit Code" (libsamplerate, samplerate_best)
http://wiki.archlinux.org/index.php/MPD ... _with_ALSA
http://mpd.wikia.com/wiki/Tuning#Sample ... SS_does.3F

4. An algorithm might be very nice, but its implementation into ALSA might be awful. What is more, 24bit sound can be converted to 16bits, then resampled (in a terrible way), and then converted back to 24bit, as the Russian guru revealed.

You claim that:
cesium wrote: most people are/would be happy with current quality.


I have another opinion. In a word, several Russian users have already enabled "Production quality" with OSS4 and reported a dramatic improvement in sound quality.
igorzwx
Supporter
 
Posts: 998
Joined: Sun Jun 28, 2009 9:31 pm

Re: How to enable "production quality with extra precision"?

Postby Temüjin » Sun Jan 17, 2010 2:51 am

If, for example, a user is not satisfied by sound quality, he might be advised to make his own resampler. Absolute freedom, in other words.

Excellent suggestions, and your patch is... where? :wink:
Temüjin
Member
 
Posts: 84
Joined: Tue Jul 24, 2007 7:55 pm
Location: Pennsylvania, USA

Re: How to enable "production quality with extra precision"?

Postby igorzwx » Sun Jan 17, 2010 3:40 am

Temüjin wrote:
If, for example, a user is not satisfied by sound quality, he might be advised to make his own resampler. Absolute freedom, in other words.

Excellent suggestions, and your patch is... where? :wink:


Do you want to say that nobody is going to fix this bug?
igorzwx
Supporter
 
Posts: 998
Joined: Sun Jun 28, 2009 9:31 pm

Re: How to enable "production quality with extra precision"?

Postby Temüjin » Sun Jan 17, 2010 5:50 am

No, but I want you to realize that this project (like most open-source) is limited by developer manpower, and that you've made your point. If you feel strongly about the issue, I'm sure the OSS developer community would be glad to accept any legitimate contributions you could make.
Temüjin
Member
 
Posts: 84
Joined: Tue Jul 24, 2007 7:55 pm
Location: Pennsylvania, USA

Re: How to enable "production quality with extra precision"?

Postby igorzwx » Sun Jan 17, 2010 7:04 pm

Temüjin wrote:No, but I want you to realize that this project (like most open-source) is limited by developer manpower, and that you've made your point. If you feel strongly about the issue, I'm sure the OSS developer community would be glad to accept any legitimate contributions you could make.


Dear Temüjin!

Many thanks for the invitation, but I have to learn something about Linux, before I would be able to contribute something useful. Perhaps, you may help me with learning as usual. You know, I prefer learning-by-doing, that is, solving practical problems.

In short, I do have a practical problem. I have already installed Arch Linux with OSS4. Everything seems to work, but the sound quality is very bad. I have already installed ABS and began to think how to recompile OSS4 to enable "Production quality".

Could you please help me to solve this problem.

Best regards,
Igor
igorzwx
Supporter
 
Posts: 998
Joined: Sun Jun 28, 2009 9:31 pm

Re: How to enable "production quality with extra precision"?

Postby igorzwx » Fri Mar 26, 2010 7:32 am

Temüjin wrote:
If, for example, a user is not satisfied by sound quality, he might be advised to make his own resampler. Absolute freedom, in other words.

Excellent suggestions, and your patch is... where? :wink:


Hi, Temüjin!

(!!!) It seems that no patches are needed to fix the problem.
For Arch Linux, it might be sufficient to edit PKGBUILD script.

In Arch Wiki, there is a manual "Patching_in_ABS"
http://wiki.archlinux.org/index.php/Patching_in_ABS
QUOTE:
"If you need only to change one or two lines in a file (ie: a Makefile), you may be better off investigating the properties of sed instead."

You need simply to apply "sed" command with certain options before and after "configure" script.
Just open PKGBUILD script with a text editor and add two commands.

"sed" command is explained here:
http://en.wikipedia.org/wiki/Sed
QUOTE:
"sed (stream editor) is a Unix utility that (a) parses text files and (b) implements a programming language which can apply textual transformations to such files."

If you know how to use sed (stream editor), you can easily fix this problem in Arch Linux.

A similar solution may work for Gentoo Linux.

--------------------------------------------------------------------------------------
To test this hypothesis, I made an experiment, that is, a simple hack.
It can be easily reproduced.

PKGBUILD script and patches can be downloaded through the help of ABS
http://wiki.archlinux.org/index.php/ABS

The source code can be downloaded with this command:

makepkg -o oss

The Algorithm:
1. remove "configure" from PKGBUILD script.
2. edit "configure" script
3. apply "configure" script
4. edit /kernel/framework/include/local_config.h

To build the package, simply use the command:

$ makepkg -s

To install, run (as root):

# pacman -U oss-4.2_2002-2-i686.pkg.tar.gz

NOTE: Before running "makepkg -s", you have to repack the source code, calculate md5sum, and correct it in the PKGBUILD script.

To skip upgrading OSS-package, you can make this:

# gedit /etc/pacman.conf

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
IgnorePkg = oss
#IgnoreGroup =

----------------------------------------------------------------------------------------------------------------------------
The problem is already solved. I have already "Production quality" enabled on Arch Linux.
OSS was recompiled and fixed.
OSS package was created and installed.
igorzwx
Supporter
 
Posts: 998
Joined: Sun Jun 28, 2009 9:31 pm

Re: How to enable "production quality with extra precision"?

Postby feli33 » Sat May 15, 2010 5:35 pm

well MIN 6,MAX 6 does result in FAST only. gentoo.
5/6 ,same
3/6 or 3/7 works on gentoo, highest SRC is 5, production NO PRECISION.

Setting 7 in configure, causes to set local_config to 3. You can edit that too, but 6 is the highest and is extra precision.
Setting 6 in configure is enough for getting the highest possible at this time without need to change localconfig.

There is a different reason for getting only mode 5. With 3/6 or 3/7, highest is Production NO Precision.
Mode 6 is disabled in the source because it causes crash.
feli33
New Member
 
Posts: 5
Joined: Sat May 15, 2010 4:23 pm

Re: How to enable "production quality with extra precision"?

Postby igorzwx » Thu Jul 22, 2010 4:31 pm

feli33 wrote:well MIN 6,MAX 6 does result in FAST only. gentoo.
5/6 ,same
3/6 or 3/7 works on gentoo, highest SRC is 5, production NO PRECISION.

Setting 7 in configure, causes to set local_config to 3. You can edit that too, but 6 is the highest and is extra precision.
Setting 6 in configure is enough for getting the highest possible at this time without need to change localconfig.

There is a different reason for getting only mode 5. With 3/6 or 3/7, highest is Production NO Precision.
Mode 6 is disabled in the source because it causes crash.


Many thanks!

If I understood you correctly, there is a little hope to get "production quality with extra precision" in the near future. On the other hand, the so-called "production quality" (without extra precision) is certainly better than severely distorted sound with the so-called "High quality".

The good news is that "production quality" is easy to enable. Many thanks for the hint.

TO SUMMARIZE: No patch is needed to fix the oss package for Arch. One may simply add a proper sed command before "configure" in PKGBILD script. This command should correct the configure script "on the fly". To be fair, I have never used such magic tools, but it is rumoured that certain hackers know how to use sed http://en.wikipedia.org/wiki/Sed

Perhaps, something like this:
Code: Select all
sed -e 's/oldstuff/newstuff/g' inputFileName > outputFileName

sed -i.bak -e 's/GRC_MAX_QUALITY=3/GRC_MAX_QUALITY=6/g' configure



HOWTO: An easy way to re-compile OSS4 [Arch Linux] to enable Production quality

Step 1: Install ABS (Arch Build System)
http://wiki.archlinux.org/index.php/ABS

Upgrade your system (as root):

# pacman -Syy

# pacman -Syu

Install abs and base-devel

# pacman -S abs

# pacman -S base-devel

Download the ABS tree:

# abs

Your ABS tree is now created under /var/abs
The build files are located in corresponding folders, e.g. /var/abs/<repo>/<pkgname>

NOTE: The abs command should be run periodically to keep in sync with the official repositories.

Step 2: Create a folder for recompilation:

$ mkdir ~/Builds

$ cd ~/Builds

$ mkdir oss-recompilation-exp3

$ cd oss-recompilation-exp3

Step 3: Copy oss package to your build folder

$ mkdir oss

$ cp -r /var/abs/community/oss/* ~/Builds/oss-recompilation-exp3/oss

$ cd oss

Code: Select all
$ ls
oss.install 
oss.rc 
oss.rm-init-scripts.patch 
oss.soundon.patch 
PKGBUILD


As a result, we have a build folder ~/Builds/oss-recompilation-exp3/oss with five magic scripts inside.

Step 4: Now we can execute a secret esoteric command:

$ makepkg --nobuild

Let us see the result:

Code: Select all
$ ls
oss.install 
oss.rm-init-scripts.patch 
oss-v4.2-build2003-src-gpl.tar.bz2 
src
oss.rc       
oss.soundon.patch         
PKGBUILD


Step 5: Now we have to edit the configure script to enable "production quality" (it depends on the package version, check the src folder in any case):

gedit ./src/oss-v4.2-build2003-src-gpl/configure

We have to change "GRC_MAX_QUALITY=3" to "GRC_MAX_QUALITY=6"

OLD:
Code: Select all
# Set GRC3 min/max conversion quality setting to 3 to conserve space.
# TODO: Add support for configurable quality settings.
GRC_MIN_QUALITY=3
GRC_MAX_QUALITY=3
export GRC_MIN_QUALITY GRC_MAX_QUALITY


NEW:
Code: Select all
# Set GRC3 min/max conversion quality setting to 3 to conserve space.
# TODO: Add support for configurable quality settings.
GRC_MIN_QUALITY=3
GRC_MAX_QUALITY=6
export GRC_MIN_QUALITY GRC_MAX_QUALITY


Step 6: Now we can compile the package we need:

$ makepkg --noextract

This command created the package oss-4.2_2003-1-i686.pkg.tar.xz

To check whether "production quality" was enabled, I opened the file

gedit ./src/build/kernel/framework/include/local_config.h

"production quality" was enabled indeed:

Code: Select all
#define CONFIG_OSS_GRC_MIN_QUALITY 3
#define CONFIG_OSS_GRC_MAX_QUALITY 6


Step 7: Re-install OSS

If you have already OSS installed, you have to purge it away.

1. Close all audio apps

2. Remove mixer applet from the panel.

3. kill ossxmix

$ killall ossxmix

4. Stop OSS4 (as root)

# soundoff

5. Remove OSS4 (as root)

# pacman -Rd oss

# rm -rf /usr/lib/oss

Now you can install your recompiled package (as root):

# pacman -U oss-4.2_2003-1-i686.pkg.tar.xz


IMPORTANT: Skip the OSS package from being upgraded (in /etc/pacman.conf )

To skip upgrading OSS package, add "IgnorePkg=oss" to the pertinent section.

Run as root:

# gedit /etc/pacman.conf

Code: Select all
# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
IgnorePkg   = oss
#IgnoreGroup =


Now you can start the OSS daemon (as root)

# /etc/rc.d/oss start

To test OSS, run

$ osstest

To launch the OSS Mixer GUI, run

$ ossxmix

Now you should have the "production quality" option in the OSS mixer:

Code: Select all
$ ossmix vmix0-src Production
Value of mixer control vmix0-src set to Production
$ ossmix | grep vmix0-src
vmix0-src <Fast|High|High+|Production|OFF> (currently Production)


See also: http://wiki.archlinux.org/index.php/OSS

Thanks to Cesium and Feli33!
igorzwx
Supporter
 
Posts: 998
Joined: Sun Jun 28, 2009 9:31 pm

Re: How to enable "production quality with extra precision"?

Postby igorzwx » Fri Jul 23, 2010 11:29 pm

Now it is very simple! "Patching on the fly" works as it should.

[Arch Linux]: How to recompile OSS to enable Production quality

It is suggested that you have the Arch Build System installed
http://wiki.archlinux.org/index.php/ABS

Step 1: Refresh the ABS tree (as root):

# abs

Step 2: Create a folder for recompilation

$ mkdir ~/Builds

$ cd ~/Builds

$ mkdir oss-recompilation-exp5

$ cd oss-recompilation-exp5

Step 3: Copy the oss package to your build folder

$ cp -r /var/abs/community/oss ./

$ cd oss

Code: Select all
$ ls
oss.install 
oss.rc 
oss.rm-init-scripts.patch 
oss.soundon.patch 
PKGBUILD


Step 4: Edit the PKGBUILD script

$ gedit ./PKGBUILD

Add the following line before "configure":

sed -i.bak -e 's/GRC_MAX_QUALITY=3/GRC_MAX_QUALITY=6/g' ${srcdir}/${_dir}/configure

OLD:
Code: Select all
# Create build directory and configure
mkdir build && cd build
${srcdir}/${_dir}/configure --enable-libsalsa=NO || return 1


NEW:
Code: Select all
# Create build directory and configure
mkdir build && cd build
sed -i.bak -e 's/GRC_MAX_QUALITY=3/GRC_MAX_QUALITY=6/g' ${srcdir}/${_dir}/configure
${srcdir}/${_dir}/configure --enable-libsalsa=NO || return 1


Step 5: Now we can compile the OSS package:

$ makepkg

Let us see the result:

Code: Select all
$ ls
oss-4.2_2003-1-i686.pkg.tar.xz 
oss.rm-init-scripts.patch           
pkg
oss.install                     
oss.soundon.patch                   
PKGBUILD
oss.rc                         
oss-v4.2-build2003-src-gpl.tar.bz2 
src


Thus, the package oss-4.2_2003-1-i686.pkg.tar.xz was created.

To check whether "production quality" was enabled, I opened the file

$ gedit ./src/build/kernel/framework/include/local_config.h

"Production quality" was enabled indeed:

Code: Select all
/*
* Automatically generated by the configure script (srcconf.c) - Do not edit.
*/
#define CONFIG_OSS_GRC_MIN_QUALITY 3
#define CONFIG_OSS_GRC_MAX_QUALITY 6
#define CONFIG_OSS_VMIX
#define CONFIG_OSS_VMIX_FLOAT
#define CONFIG_OSS_MIDI
#define OSS_CONFIG_OPTIONS "--enable-libsalsa=NO"


Step 6: Remove (purge) OSS, if you have it installed

1. Close all audio apps

2. Remove mixer applet from the panel.

3. kill ossxmix

$ killall ossxmix

4. Stop OSS (as root)

# soundoff

5. Remove OSS (as root)

# pacman -Rd oss

# rm -rf /usr/lib/oss

Step 7: Install the recompiled OSS package (as root):

# pacman -U oss-4.2_2003-1-i686.pkg.tar.xz

Step 8: Skip the OSS package from being upgraded (as root)

# gedit /etc/pacman.conf

Add "IgnorePkg = oss"

Code: Select all
# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
IgnorePkg   = oss
#IgnoreGroup =


Step 9: Start the OSS daemon (as root)

# /etc/rc.d/oss start

Step 10: Testing and configuration

Code: Select all
$ osstest
Sound subsystem and version: OSS 4.2 (b 2003/201007232043) (0x00040100)
Platform: Linux/i686 2.6.34-ARCH #1 SMP PREEMPT Mon Jul 5 21:03:38 UTC 2010

*** Scanning sound adapter #-1 ***
/dev/oss/oss_via823x0/pcm0 (audio engine 0): VIA VT8233
- Performing audio playback test...
  <left> OK <right> OK <stereo> OK <measured srate 47970.00 Hz (-0.06%)>

*** All tests completed OK ***


To launch the OSS Mixer GUI, run

$ ossxmix

Now you should have the "Production quality" option in the OSS mixer:

Code: Select all
$ ossmix | grep vmix0-src
vmix0-src <Fast|High|High+|Production|OFF> (currently Fast)
$ ossmix vmix0-src Production
Value of mixer control vmix0-src set to Production
$ ossmix | grep vmix0-src
vmix0-src <Fast|High|High+|Production|OFF> (currently Production)


See also: http://wiki.archlinux.org/index.php/OSS
Attachments
PKGBUILD.tar.bz2
PKGBUILD script for OSS
(1.54 KiB) Downloaded 742 times
igorzwx
Supporter
 
Posts: 998
Joined: Sun Jun 28, 2009 9:31 pm

Re: How to enable "production quality with extra precision"?

Postby plmegalo » Sun Jul 25, 2010 8:44 pm

Hi Igor,

Add this information, hope it will be relevant.

I've just compiled OSSv4 versus 4.2 build 2003 with Production quality with a seemingly simple hint under Debian Lenny and Fedora 13 :
From the original 4front gpl source package, first, as already known from you and cesium, simply edit "configure" file to put GRC_MAX_QUALITY to 7 but also...
edit setup/srcconf.c (program that generate local_config.h) and change the line (#1281 in amd_64 package, but maybe different in others) :
Code: Select all
   int grc_min=3, grc_max=3; // GRC3 min/max quality settings

to
Code: Select all
   int grc_min=3, grc_max=7; // GRC3 min/max quality settings


And then compile as you usually do !
That way, modifications are made from the start and everything can be packaged or compiled in one single shot !

But perhaps I missed a point. Anyway It works like a charm for me on a Debian Lenny and on Fedora 13 !

[EDIT] Just to confirm, I agree definetely with you Igor, "High quality" is really awfull, nearly worst than ALSA :lol: ! ;) [/EDIT]

See yu
plmegalo
Member
 
Posts: 11
Joined: Fri Sep 25, 2009 7:21 am

Re: How to enable "production quality with extra precision"?

Postby igorzwx » Sun Jul 25, 2010 9:56 pm

plmegalo wrote:Hi Igor,

Add this information, hope it will be relevant.

I've just compiled OSSv4 versus 4.2 build 2003 with Production quality with a seemingly simple hint under Debian Lenny and Fedora 13 :
From the original 4front gpl source package, first, as already known from you and cesium, simply edit "configure" file to put GRC_MAX_QUALITY to 7 but also...
edit setup/srcconf.c (program that generate local_config.h) and change the line (#1281 in amd_64 package, but maybe different in others) :
Code: Select all
   int grc_min=3, grc_max=3; // GRC3 min/max quality settings

to
Code: Select all
   int grc_min=3, grc_max=7; // GRC3 min/max quality settings


And then compile as you usually do !
That way, modifications are made from the start and everything can be packaged or compiled in one single shot !

But perhaps I missed a point. Anyway It works like a charm for me on a Debian Lenny and on Fedora 13 !

[EDIT] Just to confirm, I agree definetely with you Igor, "High quality" is really awfull, nearly worst than ALSA :lol: ! ;) [/EDIT]

See yu


Hi!
I am happy to see you again.

It seems that it is sufficient to set GRC_MAX_QUALITY to 6 (not 7)
I have not tried this on Ubuntu/Debian, but it works perfectly on Arch, and it is said to work on Gentoo.

You may try an experiment on Arch LiveCD (without installing anything on computer):
1. boot Arch LiveCD
2. remove ALSA (and unload ALSA modules)
3. compile OSS4 and install it (all these will vanish after reboot)

see:
HOWTO: OSS4 and Skype on a LiveCD
viewtopic.php?f=3&t=3933

NOTE: That Arch LiveCD is actually for pen-testing. You may try the tools too, if you know what they are (otherwise, you may not find them, of course).
http://en.wikipedia.org/wiki/Penetration_test
igorzwx
Supporter
 
Posts: 998
Joined: Sun Jun 28, 2009 9:31 pm

Re: How to enable "production quality with extra precision"?

Postby plmegalo » Sun Jul 25, 2010 10:44 pm

About 6 and 7 I missed that you're right ! I've just tried and it's cool indeed.

For Arch, I will test it when I have more time (36 hours day :lol:) I think. For the moment I'm fairly well on Debian and Fedora. Probably I'll try Arch on a VM once !
I really find the pkgbuild a bit too complicated to me. I'm used to standard compilation or deb or rpm for the moment and not so a power user of them ;) !

Thanks for the tips, really useful !

If anybody needs a 64 bits rpm for fedora 13 or a .deb for Debian Lenny with production quality on, then just ask, I'll be glad to give them !

See yu !

Oh just one thing : don't confuse between Debian and Ubuntu, please ! :lol: !
plmegalo
Member
 
Posts: 11
Joined: Fri Sep 25, 2009 7:21 am

Re: How to enable "production quality with extra precision"?

Postby igorzwx » Sun Jul 25, 2010 11:03 pm

plmegalo wrote:I really find the pkgbuild a bit too complicated too me.

I am completely ignorant in shell scripting and in Linux in general, and, nevertheless, I feel very comfortable with Arch. What you really need is ordinary common sense and a few Arch LiveCDs (to borrow some config files, or imitate some "working solutions"). It is very subjective, of course.

plmegalo wrote: Probably I'll try Arch on a VM once !

To try Arch on VM is the same as to smell flowers through a gas mask. Arch is "close to metal", first of all (you may smell it, if without a gas mask).

plmegalo wrote:Oh just one thing : don't confuse between Debian and Ubuntu, please ! :lol: !

Debian = Ubuntu = Fedora = SUSE (and so on), from the standpoint of the true believers in the Arch Way
http://wiki.archlinux.org/index.php/Beg ... e_Arch_Way
In this sense, Arch (as the true faith) might be very addictive. One may really need common sense to stay immune. There is a nice movie about such things
http://www.youtube.com/watch?v=qmlYe2KS0-Y


EDIT: What is crucial (for Arch) is common sense, because your freedom of choice is fundamentally restricted in the sense that you are forced to make choice yourself. If something does not work as it should, or it goes completely astray, you have to blame yourself, for it was your personal choice to do things in this or that way. To install Arch is a real challenge, and the nature of this challenge is rather psychological than technical. No special technical knowledge is required, but a kind of psychological training (a sort of radical Zen, or else) might be very helpful.
igorzwx
Supporter
 
Posts: 998
Joined: Sun Jun 28, 2009 9:31 pm

Re: How to enable "production quality with extra precision"?

Postby plmegalo » Mon Jul 26, 2010 5:23 pm

igorzwx wrote:Debian = Ubuntu = Fedora = SUSE (and so on), from the standpoint of the true believers in the Arch Way
.

Looks like a troll ... About Arch or Gentoo or any, to my "common sense", the truth is that they are all linux distribs as others. Reminds me of some white people expression finding every black people look the same. Mainly look the same because we got a personal distance with them...
What I think is that to have the choice is really to use what you feel comfortable with, not to use what "common sense" definition of one person intend to be a choice. I choose Debian (for the moment) as my main OS, because I only care about having freely what I need, using the simplest and shortest way to have the more stable and accurate softwares for my own usage. I'm not interested of philosophical consideration, sorry. To me, this is only about computers, machines, and what I only want is that they do what I need. For my own usage, Debian is largely as customizable as Arch, as any real Linux distribution can be. Even, if you want to crap it, you can (it's hard though ;) ) :lol: !
I know that Arch is talking about minimalistic and simplest way, but what looks like common sense to you is really a torturous way to me. Looking at the pkgbuild process is a good sample of what can be felt as simple for Arch user. I really find that compiling is more simple than that and surely nearer to the metal, as you say.
I'm sorry to have to tell that Igor, but I'm a professional computer worker since more than 20 years (oooh yes :lol:), mainly on IBM mainframes and though less on Unix systems, really I know that this is about all but poetry or philosophical considerations :lol: !
So this won't be a discussion with me Igor, let's state back to sound and mainly music, because these are more artistry ;) !
plmegalo
Member
 
Posts: 11
Joined: Fri Sep 25, 2009 7:21 am

Re: How to enable "production quality with extra precision"?

Postby igorzwx » Mon Jul 26, 2010 5:49 pm

plmegalo wrote:
igorzwx wrote:Debian = Ubuntu = Fedora = SUSE (and so on), from the standpoint of the true believers in the Arch Way
.

Looks like a troll ... About Arch or Gentoo or any, to my "common sense", the truth is that they are all linux distribs as others. Reminds me of some white people expression finding every black people look the same. Mainly look the same because we got a personal distance with them...
What I think is that to have the choice is really to use what you feel comfortable with, not to use what "common sense" definition of one person intend to be a choice. I choose Debian (for the moment) as my main OS, because I only care about having freely what I need, using the simplest and shortest way to have the more stable and accurate softwares for my own usage. I'm not interested of philosophical consideration, sorry. To me, this is only about computers, machines, and what I only want is that they do what I need. For my own usage, Debian is largely as customizable as Arch, as any real Linux distribution can be. Even, if you want to crap it, you can (it's hard though ;) ) :lol: !
I know that Arch is talking about minimalistic and simplest way, but what looks like common sense to you is really a torturous way to me. Looking at the pkgbuild process is a good sample of what can be felt as simple for Arch user. I really find that compiling is more simple than that and surely nearer to the metal, as you say.
I'm sorry to have to tell that Igor, but I'm a professional computer worker since more than 20 years (oooh yes :lol:), mainly on IBM mainframes and though less on Unix systems, really I know that this is about all but poetry or philosophical considerations :lol: !
So this won't be a discussion with me Igor, let's state back to sound and mainly music, because these are more artistry ;) !


Perhaps, I was misunderstood. I did tell that I am completely ignorant in "computer science", and, therefore, I tend to rely on what I have (or believe to have), that is, common sense. I do not write those PKGBUILD scripts, and I do not understand them, or course. I take the ready ones and modify them, if I need. One may also compile in the traditional way, if he wants. However, it might be more convenient to have a package. There is a similar system for building packages (and packaging repositories) for Debian/Ubuntu (dev scripsts, etc.), but it seems to me much more difficult to use. It is my subjective opinion, of course, but you may try it, if you want. See, for example: viewtopic.php?f=3&t=3375#p13624


EDIT: You may try an experiment:

1. Take a computer with at least 2GB RAM (you may need a lot of RAM, because everything will be installed to RAM; all these will vanish after reboot, of course).

2. Boot Ubuntu 10.04 LiveCD

3. Install dev-scripts, etc. (it may take about 500MB of RAM for installation)

4. Recompile packages oss4-base, oss4-dev, oss4-dkms, oss4-source, oss4-gtk to enable "Production quality", using the Debian/Ubuntu Build System

The manual for recompilation and several examples you may find in that same thread
viewtopic.php?f=3&t=3375#p13624

You may create a repository for Debian and/or Ubuntu with recompiled OSS4 packages. Why not?

It seems that OSS4 packages are very easy to install on Ubuntu 10.04 from the official repository (there are in the universe repository). You may boot the LiveCD and install them (then, run osstest and so on). They will vanish after reboot, of course.


EDIT: Why not really OSS4 repository for Debian?
The packages are actually ready. You may simply need to modify a few lines in the scripts.
In a word, Temüjin is now maintaining the "audiohacks" PPA repository for Ubuntu.
https://launchpad.net/~dtl131/+archive/ppa
You may try to ask him to explain how to create a similar repository for Debian. Why not?

EDIT: Even more simple! The packages are already in Debian repositories. What you need is simply to enable "Production quality".

Code: Select all
Package oss-preserve

lenny (stable) (admin): Program to save/restore OSS mixer settings
1.1-5: alpha amd64 arm armel hppa i386 ia64 mips mipsel powerpc s390 sparc
squeeze (testing) (admin): Program to save/restore OSS mixer settings
1.1-6: amd64 armel hppa i386 ia64 kfreebsd-amd64 kfreebsd-i386 mips mipsel powerpc s390 sparc
sid (unstable) (admin): Program to save/restore OSS mixer settings
1.1-6: alpha amd64 armel avr32 hppa hurd-i386 i386 ia64 kfreebsd-amd64 kfreebsd-i386 m68k mips mipsel powerpc s390 sparc

Package oss4-base

squeeze (testing) (sound): Open Sound System - base package
4.2-build2003-1: amd64 armel hppa i386 ia64 mips mipsel powerpc s390 sparc
sid (unstable) (sound): Open Sound System - base package
4.2-build2003-1: alpha amd64 armel hppa i386 ia64 mips mipsel powerpc s390 sparc

Package oss4-dev

squeeze (testing) (devel): Open Sound System - development files
4.2-build2003-1: all
sid (unstable) (devel): Open Sound System - development files
4.2-build2003-1: all

Package oss4-dkms

squeeze (testing) (kernel): Open Sound System - DKMS module sources
4.2-build2003-1: all
sid (unstable) (kernel): Open Sound System - DKMS module sources
4.2-build2003-1: all

Package oss4-gtk

squeeze (testing) (sound): Open Sound System - simple GTK2-based mixer control
4.2-build2003-1: amd64 armel hppa i386 ia64 mips mipsel powerpc s390 sparc
sid (unstable) (sound): Open Sound System - simple GTK2-based mixer control
4.2-build2003-1: alpha amd64 armel hppa i386 ia64 mips mipsel powerpc s390 sparc


You may boot, for example, DreamLinux LiveCD http://www.dreamlinux.com.br/
enable the proper Debian repository, and recompile the OSS4 packages through the help of dev-scripts.
igorzwx
Supporter
 
Posts: 998
Joined: Sun Jun 28, 2009 9:31 pm

PreviousNext

Return to Linux

Who is online

Users browsing this forum: Google [Bot] and 1 guest