"Production" setting for vmix0-src?

OSS specific Linux discussion (x86/amd64)

Moderators: hannu, dev, cesium, kodachi

"Production" setting for vmix0-src?

Postby KayakJim » Fri Mar 19, 2010 5:44 pm

According to a few tutorials for OSS4 that I have read, everyone recommends setting the vmix0-src to "Production" within ossxmix.

The only options I have are Fast (default), High, and Off.

Was the Production setting available in previous releases and been replaced or am I missing something?

Jim
KayakJim
Member
 
Posts: 19
Joined: Fri Mar 19, 2010 5:07 pm
Location: Hendersonville, TN

Re: "Production" setting for vmix0-src?

Postby cesium » Fri Mar 19, 2010 9:19 pm

hannu disabled that out since he felt the code increased size without much of a difference for quality. You can reenable it (edit configure and change GRC_MAX_QUALITY) if you are able to build OSS. Otherwise, the most you can go is the "High" setting.
cesium
Developer
 
Posts: 902
Joined: Sun Aug 12, 2007 12:51 am

Re: "Production" setting for vmix0-src?

Postby igorzwx » Fri Mar 19, 2010 10:04 pm

cesium wrote:hannu disabled that out since he felt the code increased size without much of a difference for quality. You can reenable it (edit configure and change GRC_MAX_QUALITY) if you are able to build OSS. Otherwise, the most you can go is the "High" setting.


I have already discussed this problem with Temüjin
viewtopic.php?f=3&t=3543

It seems that it is simply a bug which is difficult to fix. Somebody should make a patch and nobody has time for this.
I was proposed to write this patch myself.
I have never made any kind of patches. Otherwise, I may try.
igorzwx
Moderator
 
Posts: 1005
Joined: Sun Jun 28, 2009 9:31 pm

Re: "Production" setting for vmix0-src?

Postby igorzwx » Fri Mar 19, 2010 10:16 pm

I did recompile OSS4 to enable "Production quality", and I have a ready deb-package. Cesium explained me basic ideas, and I made it.

However, you may better try to recompile it yourself. It is very simple.

I built OSS4 from Mercurial following this guide (Ubuntu 9.10):
https://help.ubuntu.com/community/OpenSound


1. Close all audio apps

2. Remove Gnome Volume Control from the panel.

3. kill ossxmix

killall ossxmix

4. Stop OSS4

sudo soundoff

5. Remove OSS4

sudo dpkg --purge oss-linux

-------------------------------------------
If you already compiled OSS4 from Mercurial
-------------------------------------------
Update OSS4 source and remove the old Build (if you compiled OSS4 from Mercurial)

cd /opt/oss-devel

sudo hg pull

sudo hg update

cd ~/

sudo rm -rf oss42build

mkdir oss42build

-----------------------------------------------------------------------------------


6. Install Prerequisite Packages

sudo apt-get install -y binutils libgtk2.0-0 sed gcc libc6

sudo apt-get install -y build-essential linux-headers-`uname -r` gawk libtool libgtk2.0-dev

sudo apt-get install -y libesd0 libsdl1.2debian-oss


7. Obtaining the OSS Source using Mercurial

sudo apt-get install -y mercurial

cd /opt

sudo hg clone http://mercurial.opensound.com/ oss-devel

************************************************************************

8. Edit the configure script to enable High Quality Re-Sampling

gksu gedit /opt/oss-devel/configure

OLD:
------------------------------------------------------------------------
# Set GRC3 min/max conversion quality setting to 3 to conserve space.
# TODO: Add support for configurable quality settings.
GRC_MIN_QUALITY=3
GRC_MAX_QUALITY=3
export GRC_MIN_QUALITY GRC_MAX_QUALITY
------------------------------------------------------------------------

NEW:
------------------------------------------------------------------------
# Set GRC3 min/max conversion quality setting to 3 to conserve space.
# TODO: Add support for configurable quality settings.
GRC_MIN_QUALITY=3
GRC_MAX_QUALITY=7
export GRC_MIN_QUALITY GRC_MAX_QUALITY
------------------------------------------------------------------------
************************************************************************


9. Creating a Build Directory

cd ~/

sudo rm -rf oss42build

mkdir oss42build

cd oss42build/


10. Build & Install


10.1 Configure. Execute this command:

NO_WARNING_CHECKS=yes /opt/oss-devel/configure


10.2 Edit ./kernel/framework/include/local_config.h

gedit ./kernel/framework/include/local_config.h

OLD:
#define CONFIG_OSS_GRC_MAX_QUALITY 3

NEW:
#define CONFIG_OSS_GRC_MAX_QUALITY 7



10.3 Make

make

sudo make deb

sudo dpkg -i oss*.deb

sudo reboot


It should work now.


*****************************************************************
READ:
viewtopic.php?f=3&t=3543
igorzwx
Moderator
 
Posts: 1005
Joined: Sun Jun 28, 2009 9:31 pm

Re: "Production" setting for vmix0-src?

Postby KayakJim » Fri Mar 19, 2010 10:40 pm

As I understand it, all of the posts I have read on the web have stated that the Production setting has a dramatic improvement in sound quality.

I did compile from mercurial and will make the change to enable the Production setting.

What is involved in making the fix? I have a programming background. Even though I haven't touched anything other than web scripting for the past 10 years, I should probably be able to get back into the groove and help out a bit.

Thank you everyone for the replies, information, and help! :)
KayakJim
Member
 
Posts: 19
Joined: Fri Mar 19, 2010 5:07 pm
Location: Hendersonville, TN

Re: "Production" setting for vmix0-src?

Postby igorzwx » Fri Mar 19, 2010 10:55 pm

KayakJim wrote:As I understand it, all of the posts I have read on the web have stated that the Production setting has a dramatic improvement in sound quality.

I did compile from mercurial and will make the change to enable the Production setting.

What is involved in making the fix? I have a programming background. Even though I haven't touched anything other than web scripting for the past 10 years, I should probably be able to get back into the groove and help out a bit.

Thank you everyone for the replies, information, and help! :)


Most probably, it is something simple.
I have already changed to Arch Linux, and the same problem with "Production quality".
The package is already patched with some other patches, they might be used as examples.

Arch Linux might be very convenient for such experiments, but the problem is that I installed it (first time) a few weeks ago.
I have to learn something, before making such experiments.

KayakJim wrote:As I understand it, all of the posts I have read on the web have stated that the Production setting has a dramatic improvement in sound quality.


I agree. It is impossible to believe that "Production quality" was simply disabled.
I made a kind of research (experiments, etc.), you may read this:
viewtopic.php?f=3&t=3543
igorzwx
Moderator
 
Posts: 1005
Joined: Sun Jun 28, 2009 9:31 pm

Re: "Production" setting for vmix0-src?

Postby KayakJim » Fri Mar 19, 2010 11:29 pm

igorzwx wrote:8. Edit the configure script to enable High Quality Re-Sampling
gksu gedit /opt/oss-devel/configure

OLD:
Code: Select all
# Set GRC3 min/max conversion quality setting to 3 to conserve space.
# TODO: Add support for configurable quality settings.
GRC_MIN_QUALITY=3
GRC_MAX_QUALITY=3
export GRC_MIN_QUALITY GRC_MAX_QUALITY

NEW:
Code: Select all
# Set GRC3 min/max conversion quality setting to 3 to conserve space.
# TODO: Add support for configurable quality settings.
GRC_MIN_QUALITY=3
GRC_MAX_QUALITY=7
export GRC_MIN_QUALITY GRC_MAX_QUALITY


10.2 Edit ./kernel/framework/include/local_config.h
gedit ./kernel/framework/include/local_config.h

OLD:
Code: Select all
#define CONFIG_OSS_GRC_MAX_QUALITY 3


NEW:
Code: Select all
#define CONFIG_OSS_GRC_MAX_QUALITY 7



That worked perfectly and I now have Production setting available in ossxmix.

Thank you very much for the help igorzwx! :)
KayakJim
Member
 
Posts: 19
Joined: Fri Mar 19, 2010 5:07 pm
Location: Hendersonville, TN

Re: "Production" setting for vmix0-src?

Postby igorzwx » Fri Mar 19, 2010 11:36 pm

KayakJim wrote:
igorzwx wrote:8. Edit the configure script to enable High Quality Re-Sampling
gksu gedit /opt/oss-devel/configure

OLD:
Code: Select all
# Set GRC3 min/max conversion quality setting to 3 to conserve space.
# TODO: Add support for configurable quality settings.
GRC_MIN_QUALITY=3
GRC_MAX_QUALITY=3
export GRC_MIN_QUALITY GRC_MAX_QUALITY

NEW:
Code: Select all
# Set GRC3 min/max conversion quality setting to 3 to conserve space.
# TODO: Add support for configurable quality settings.
GRC_MIN_QUALITY=3
GRC_MAX_QUALITY=7
export GRC_MIN_QUALITY GRC_MAX_QUALITY


10.2 Edit ./kernel/framework/include/local_config.h
gedit ./kernel/framework/include/local_config.h

OLD:
Code: Select all
#define CONFIG_OSS_GRC_MAX_QUALITY 3


NEW:
Code: Select all
#define CONFIG_OSS_GRC_MAX_QUALITY 7



That worked perfectly and I now have Production setting available in ossxmix.

Thank you very much for the help igorzwx! :)


It was actually a solution proposed by Cesium.
igorzwx
Moderator
 
Posts: 1005
Joined: Sun Jun 28, 2009 9:31 pm

Re: "Production" setting for vmix0-src?

Postby KayakJim » Fri Mar 19, 2010 11:49 pm

igorzwx wrote:It was actually a solution proposed by Cesium.

Well then "Thank You" to Cesium for originally providing it and to you for passing it along to me. :D
KayakJim
Member
 
Posts: 19
Joined: Fri Mar 19, 2010 5:07 pm
Location: Hendersonville, TN


Return to Linux

Who is online

Users browsing this forum: No registered users and 1 guest